You Need Windows 7 Sp1 To Install Internet Explorer 11

Posted on
Explorer
  1. Need Windows 7 Sp1 To Install Internet Explorer 11
Sp1

Windows 7 SP1 will not install - posted in Windows 7: I am new to this forum. I have been prompted to upgrade my browser to IE11. When attempting to do so, I get a prompt indicating Windows 7 SP1. The recommended (and easiest) way to get SP1 is to turn on automatic updating in Windows Update in Control Panel and wait for Windows 7 to notify you that SP1 is ready to install. It takes about 30 minutes to install, and you'll need to restart your computer about halfway through the installation.

  1. Download NTLite and install it (a portable mode is available during install). On the first launch select the free license and press OK. In the NTLite window click the Add button and browse to the folder you extracted/copied in step 2, click Select Folder. Windows 7 will then show in the Source list.
  2. Internet Explorer 11 is a freeware IE browser software download filed under web browsers and made available by Microsoft for Windows. The review for Internet Explorer 11 has not been completed yet, but it was tested by an editor here on a PC and a list of features has been compiled; see below.

Need Windows 7 Sp1 To Install Internet Explorer 11

Windows 7 SP1 - Internet Explorer 11 Integration en-gb
on the microsoft page for Prerequisites Needed For IE11, it gives you a list, but it isnt updated according to another post here somewhere, some have been replaced/superceeded since i updated at 7's end of mainstream support in february im i am correct.
doing a trial build to integrate IE11 only into a en_windows_7_ultimate_with_sp1_x64_dvd_u_677332.iso, with no other updates,
i added what microsoft say, but it was still showing red, other prerequisites were needed also.
heres the full list to integrate Windows6.1-KB2841134-x64.cab
2011-07-Windows6.1-KB2533623-x64.msu
2012-10-Windows6.1-KB2729094-v2-x64.msu
2012-10-Windows6.1-KB2731771-x64.msu
2013-01-Windows6.1-KB2786081-x64.msu
2013-02-Windows6.1-KB2670838-x64.msu
2013-08-Windows6.1-KB2834140-v2-x64.msu
2013-10-Windows6.1-KB2888049-x64.msu
2014-05-Windows6.1-KB2871997-v2-x64.msu
2014-09-Windows6.1-KB2970228-x64.msu
Windows6.1-KB2841134-x64.cab -- the IE11 cab file itself.
without them as a minimum, ie11 wont install.
Windows 7 'SP2' - Internet Explorer 11 Integration-KB3125574 - en-gb
yeah yeah, i know Windows6.1-KB3125574-v4-x64.msu is not a service pack, but i call it that to easily differentiate between an untouched sp1 iso and an sp1 iso with KB3125574 integrated.
above is the list of the prerequisites needed for ie11 integration into an untouched sp1 iso.
with KB3125574, one of those prerequisites is already installed and others are now 'not applicable'.
so here is the revised list to install ie11 and prerequisites onto a windows 7 system that has been updated with KB3125574, or using ntlite to integrate KB3125574 and ie11 onto a sp1 iso.
KB3125574(and prerequisites) would have to be integrated 1st.
2012-10-Windows6.1-KB2729094-v2-x64.msu
2013-02-Windows6.1-KB2670838-x64.msu
2013-08-Windows6.1-KB2834140-v2-x64.msu
2014-09-Windows6.1-KB2970228-x64.msu
EIE11_EN-GB_MCM_WIN764.EXE - used for this test on an installed system or
IE11-Windows6.1-KB2841134-x64.cab - normally used for ntlite direct integration.
xx