Windows Osx El Capitain 10.11 64 Bit Download

Posted on

This page lists the current status of TASCAM interface drivers for Windows 10 and Mac OS X 10.11. Even if your interface is compatible, please check that your DAW and other software is compatible before upgrading. If your interface is not listed, it is no longer possible to develop new drivers for that product.

MAC OS X 10.11 El Capitan For Windows PC.zip. MAC OS X 10.11 El Capitan For Windows PC.zip (9.72 GB) Choose free or premium download. FAST INSTANT DOWNLOAD.

DownloadWindows Osx El Capitain 10.11 64 Bit Download

Updated Jan 13, 2016:

Windows Osx El Captain 10.11 64 Bit Download Windows 7

Windows 10OS X El Capitan (10.11)
ASIO driver/
setting software
WDN driverFirmwareAudio/MIDISetting softwareFirmware
US-2x2v1.02 or higherv1.01 or higherCompatible/class complientv1.02 or higherv1.01 or higher
US-4x4v1.02 or higherv1.01 or higherCompatible/class complientv1.02 or higherv1.01 or higher
US-16x08v1.03 or higherv1.00 or higherCompatible/class complientv1.00 or higherv1.00 or higher
US-20x20v1.00 or higherv1.00 or higherCompatible/class complientv1.00 or higherv1.00 or higher
USB 3.0 requires OSX 10.11.2
UH-7000v1.02 or higherv1.07 or higherv1.30rc4 or higher
US-322v1.04 or higherv1.03 or higherv3.22rc5 or higher
US-366v1.04 or higherv1.03 or higherv3.22rc5 or higher
US-122MK2Currently testingCurrent version (driver v3.00d8/firmware v2.03) is not compatible.
A new version is under development.
US-144MK2Currently testingCurrent version (driver v3.00d8/firmware v2.03) is not compatible.
A new version is under development.
US-100ASIO is
not supported
Currently testingCurrently testing
US-125MASIO is
not supported
Currently testingCurrently testing
US-200Currently testingCompatible/class complient
US-600Currently testingCompatible/class complient
US-1200Currently testingv3.22rc1 or higher (beta release, El Capitan only)
US-1641Currently testingv3.22rc1 or higher (beta release, El Capitan only)
US-1800No need to update
v2.05 driver or higher is
compatible
No need to update
v1.00 firmware or later is
compatible
v3.0.21.b1 or higher (beta release, El Capitan only)v1.00 or higher
US-2000Currently testingv3.22rc1 or higher (beta release, El Capitan only)
IF-FW/DM mkIICurrently testingv1.30f10 or higher